Jump to content

1Password — Search and open 1Password items

Recommended Posts

Welcome @Cristina,


When asking about an existing Workflow, it’s best to use its own forum thread. While it may seem that starting a new thread could give your problem visibility, it fragments the discussion and makes it less likely the author and users of the workflow (the people who can help) will see it. I’ve moved your post to the correct location.


Please follow the steps in the second post, namely running !1pdiagnostic.

Link to comment

Hello, I set up 1Password 8 workflow:

  • Installed 1P CLI
  • Turned on CLI in 1P Developer tab
  • Set up touch
  • Logged in using CLI
  • Added 1Password 8 workflow to Alfred

Initially I was getting an error in the debugger: "json text did not start with array or object and option to allow fragments not set".


After not finding much in the way of help, I decided to try: Force Update Items. Now the error is gone and I see logging of items in my vaults, but I still can't get any results when I type 1p. 


I also tried changing the config for 1p to something else and that doesn't seem to work either even after quitting and restarting Alfred.


When I run `op item list` I do get the list of my items, no errors.

Any ideas of what I could have missed? I am using zsh in case that is of consequence.


Here is the diagnostics output: 

### Workflow version

### Alfred version

### macOS version

### Architecture

### Preferences
Dict {

### 1Password version

### op version

### Launchd job
Loaded: -    0    com.alfredapp.vitor.1password

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...