Jump to content

1Password — Search and open 1Password items


Recommended Posts

hi @vitor

thanks for your great work

 

I've already updated the CLI tool and tried the solutions in previous posts (i.e. used :1pextras to force update and reset workflow). 

I only have 1 account and 1 vault

 

Still have same problem of no logins showing after i type 1p and stuck on "updating items will take a few seconds"

 

do you have any other suggestions?

thanks

Link to comment

I'm not very technical so don't understand what can you use op in Terminal means?

I can open terminal and type op which brings up a list of commands. for 1password CLI which I don't understand

 

- can you point me to a relevant guide that I might be able to read ?

 

Thanks

Link to comment
  • I followed instrucitons in the post you linked i.e listing vaults via op: "op vault list". No 2nd account present.  
  • I tried force listing vaults from that account: "op account list" (copy the user id). Then execute "op vault list --account <user id goes here>". This is when you'd get asked for MFA.

 

but I was never asked for MFA and get the following terminal output:

 

 

Last login: Mon Jan  9 22:52:38 on ttys000

smeen@192-168-1-158 ~ % op vault list [REDACTED]

[ERROR] 2023/01/09 23:18:14 expected at most 0 arguments but got 1 instead

Usage:  op vault list [flags]

 

Aliases:

  list, ls

 

Examples:

Get details for all vaults:

 

op vault list --format=json | op vault get -

 

Get details for vaults that a group has access to:

 

op vault list --group Security --format=json | op vault get -

 

Get details for vaults that a user has access to:

 

op vault list --user wendy_appleseed@1password.com --format=json | op vault get -

 

Flags:

      --group string   List vaults a group has access to.

  -h, --help           Get help with vault list.

      --user string    List vaults that a given user has access to.

 

To list the global flags available on every command, run  'op --help'.

smeen@192-168-1-158 ~ % 

 

 

 

any ideas?

 

thanks

 

Edited by vitor
Redacted ID
Link to comment
2 minutes ago, alfreduser8 said:

but I was never asked for MFA and get the following terminal output


Note the command you quoted and the one you typed are different. Yours was missing the --account. Try it again with that.

 

Send it over as a personal message, though, to avoid posting potentially personal information about an account or vault.

Link to comment

hi @vitor

thanks for all your help again

 

I've managed to get it working, not sure what worked but heres what i did for future reference:

 

1. deleted  old1password 4 folder from library

2. updated to new version of 1 password released yesterday

3. turned off touchID and Apple Watch unlock for iOS and 1password

4. disconnected MacBook from clamshell mode

5. restarted computer

6. in terminal typed "op vault list". then force listing vaults from that account: "op account list" (copy the user id). Then execute "op vault list --account <user id goes here>"

Link to comment
  • 2 weeks later...

Hello,

 

I'm a new user - just bought my Powerpack today and so far loving this workflow! I do come with one question, how can I change shortcuts? 

As of right now shortcuts are as following:

image.png.88ec3c04894ef0cb22daeaeb70a99bc0.png

 

Without the possibility to edit them. I would like to keep them "in line" with 1 Passwords one and to copy username I would for example like to use CMD + C.

Is there any chance to edit those?

 

 

Link to comment

Welcome @SuupaPro,

 

You can edit what each shortcut does by using their respective drop downs. You cannot add bespoke key combinations in there.

 

⌘C could technically be editable, but not to copy the username because doing so requires authentication, a deliberate choice because those can themselves be sensitive information, plus 1Password saves them in the additional_information field which is also used to store the first line of content from secure notes (which are even more sensitive information).

Link to comment

Hey,

 

Yes, I saw that I could change what the shortcut is doing itself but I wasn't sure how to edit the shortcut itself.

In the 1password app I have those shortcuts:

image.thumb.png.2c3fb5d37128085c140abec2264cc7e3.png

 

What I would like to do is to simply keep the same shortcuts in Alfred 1p workflow so whether I bring 1Password Show Quick Access or Alfred 1p I would be able to use the same shortcut to copy username/password.

Link to comment

I understand the request, but as mentioned above we cannot add random shortcuts to any action, the listed ones are what’s possible. The alternative would be changing 1Password’s shortcuts to match the ones in the workflow.

 

There’s also the matter that a third-party integration is always limited by the vendor’s decisions: 1Password knows when it’s unlocked and can give you access to any data at that point, but external tools (like Alfred) either have to request the information at specific points or gobble it up beforehand. Due to the nature of 1Password and the data it stores, it is a very deliberate decision to ask for the minimum possible and be extra safe, which is why even copying a username requires the authentication step.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...