Jump to content
Carlos-Sz

Evernote Workflow 9 beta 3

Recommended Posts

I just want to say thank you for this workflow.  Evernote is my brain for work, and home, and you've just made accessing my notes so easy that it feels like a miracle.

 

Again, thank you for creating this workflow, and taking the time to make it function so well - even for a computer dummy like me.   :)

 

Regards,

 

Natasha

Edited by tmallone

Share this post


Link to post

 Version 5.0 is out:

  • Save the new note in an existing notebook or in a new one e.g. MyNote#MyTags#Notebook
  • Append text to an existing note
  • Automatically synchronize Evernote after a note is created or changed
  • Added ensync keyword to make Evernote synchronize
  • Added enHelp keyword

See initial post for details!

 

PS: thank you Natasha for your kind words. :)

Share this post


Link to post

The new note with selected file doesn't work for me. I have a pdf selected, and I bring up Alfred and do ennew. The "new note from finder selected file" shows the file name I selected. I select it and nothing happens.

Share this post


Link to post

The new note with selected file doesn't work for me. I have a pdf selected, and I bring up Alfred and do ennew. The "new note from finder selected file" shows the file name I selected. I select it and nothing happens.

 

I made 5 tests and all went fine but I’ll play with it more to see if I find something wrong.

 

Please try the following:

 

- Update Alfred 2 with the current pre-release

- Restart Evernote

- Restart Alfred in case you don’t want to update it

- Download and install the workflow again

Share this post


Link to post

Hi Carlos,

 

Your Evernote script just gets better and better!

 

I've noticed that neither your Evernote script or Edit with script are updating for me with Alleyoop. I've posted on the Alleyoop thread too, but it only seems to be your scripts so I thought I'd mention it here.

 

 

It tells me that there are updates available but then goes through and updates them with the old versions. For example, I have "Edit With" version 1.5. Alleyoop is telling me that there is a 1.6 available. I select to update, it send me the notification that update is complete, but then I'm left with 1.5.
 
I've now updated both manually.
 
Best,
 
Alex

Share this post


Link to post

Hi Carlos,

 

Your Evernote script just gets better and better!

 

I've noticed that neither your Evernote script or Edit with script are updating for me with Alleyoop. I've posted on the Alleyoop thread too, but it only seems to be your scripts so I thought I'd mention it here.

 

 

It tells me that there are updates available but then goes through and updates them with the old versions. For example, I have "Edit With" version 1.5. Alleyoop is telling me that there is a 1.6 available. I select to update, it send me the notification that update is complete, but then I'm left with 1.5.
 
I've now updated both manually.
 
Best,
 
Alex

 

Thank you Alex.

 

Did you update Alleyoop manually (you have to) today/yesterday? It seems to be working fine here with the latest Alleyoop update.

Share this post


Link to post

Hi Carlos,

 

I'm pretty sure I did update it first, but now I've manually updated the workflows I'll have to wait for future updates to test again.

 

Sorry for not double checking.

 

 

Best,
 
Alex

Share this post


Link to post

Ok so it looks like it is working correctly. I didn't realise the expected behaviour was to now manually install after running Alleyoop.

 

Thanks for your help!

 

 

Best,
 
Alex

Share this post


Link to post

Can I piggy-back on this question.

I am using the Evernote 5.0 version of the workflow, which is a little gem. However, I can't get it to operate if there are multiple files in the buffer. If I select a single file and then hot-key the actions I get 'send to Evernote' at the bottom of the list, but if I highlight more than one file and then try the hot-key i don't get the 'send to Evernote' option at the bottom of the list.  Am I missing something here?

 

And secondly, could I get this to play nicely with Hazel? I have never succeeded with 'watched folders' but it occurs to me that if I set up a Hazel rule to watch a folder it could 'send to Evernote' automatically. Would that work and how would I do it?

Thanks for any help.

Share this post


Link to post

Ok so it looks like it is working correctly. I didn't realise the expected behaviour was to now manually install after running Alleyoop.

 

Thanks for your help!

 

 

Best,
 
Alex

 

Great Alex. If you need any help please let me know.

 

Can I piggy-back on this question.

I am using the Evernote 5.0 version of the workflow, which is a little gem. However, I can't get it to operate if there are multiple files in the buffer. If I select a single file and then hot-key the actions I get 'send to Evernote' at the bottom of the list, but if I highlight more than one file and then try the hot-key i don't get the 'send to Evernote' option at the bottom of the list.  Am I missing something here?

 

And secondly, could I get this to play nicely with Hazel? I have never succeeded with 'watched folders' but it occurs to me that if I set up a Hazel rule to watch a folder it could 'send to Evernote' automatically. Would that work and how would I do it?

Thanks for any help.

 

Hi,

 

The workflow does not accept multiple files at this time but I’ll add support for it. I’ll let you know.

 

I’ll see what I can do about Hazel.

 

Thank you for your feedback.

Share this post


Link to post

Can I piggy-back on this question.

I am using the Evernote 5.0 version of the workflow, which is a little gem. However, I can't get it to operate if there are multiple files in the buffer. If I select a single file and then hot-key the actions I get 'send to Evernote' at the bottom of the list, but if I highlight more than one file and then try the hot-key i don't get the 'send to Evernote' option at the bottom of the list.  Am I missing something here?

 

And secondly, could I get this to play nicely with Hazel? I have never succeeded with 'watched folders' but it occurs to me that if I set up a Hazel rule to watch a folder it could 'send to Evernote' automatically. Would that work and how would I do it?

Thanks for any help.

 

 

Evernote 5.1 supports multiple files. Download it now.

 

Here is a Hazel rule for Evernote: link

 

 

This is spot on. Top work!

 

Thank you.

Edited by Carlos-Sz

Share this post


Link to post

Hello.

 

First of all, thank you very much for your work in making this workflow.

 

I just installed 5.1 and yet I still am having trouble getting the workflow to work on one of my machines.

 

I have my Alfred workflows synced between an iMac and a MacBook Air using dropbox. 

 

The installation works just fine on my iMac but not on my MBA. 

 

I actually installed the workflow on my MBA too. But it won't let me create a new note using the 'ennew' command.

 

I have other workflows synced up and installed like this with no problems.

 

I was wondering if anyone else encountered such a problem and had any ideas how to fix it?

 

Thanks.

Share this post


Link to post

Hello.

 

First of all, thank you very much for your work in making this workflow.

 

I just installed 5.1 and yet I still am having trouble getting the workflow to work on one of my machines.

 

I have my Alfred workflows synced between an iMac and a MacBook Air using dropbox. 

 

The installation works just fine on my iMac but not on my MBA. 

 

I actually installed the workflow on my MBA too. But it won't let me create a new note using the 'ennew' command.

 

I have other workflows synced up and installed like this with no problems.

 

I was wondering if anyone else encountered such a problem and had any ideas how to fix it?

 

Thanks.

 

I sync mine installation too and everything is fine.

 

I’m using Alfred 2.0.3 (187).

 

Please, try to delete the workflow in both your Macs. Download it again from the initial post. Install it in your main Mac first then let the other sync after the installation.

 

You can also try to restart Alfred (not Alfred Preferences, Alfred itself).

 

Soon there will be a new version made for Alfred 2.0.3 (187). This Alfred version has some AppleScript improvements that Evernote workflow will use it for sure.

Share this post


Link to post

I sync mine installation too and everything is fine.

 

I’m using Alfred 2.0.3 (187).

 

Please, try to delete the workflow in both your Macs. Download it again from the initial post. Install it in your main Mac first then let the other sync after the installation.

 

You can also try to restart Alfred (not Alfred Preferences, Alfred itself).

 

Soon there will be a new version made for Alfred 2.0.3 (187). This Alfred version has some AppleScript improvements that Evernote workflow will use it for sure.

 

Thank you very much for the response.

 

I am using the same version of Alfred 2.0.3 (187)...

 

I followed your instructions, but I'm still having the same problem. It is puzzling.

 

Hopefully, the new version will fix it.

Share this post


Link to post

Thank you very much for the response.

 

I am using the same version of Alfred 2.0.3 (187)...

 

I followed your instructions, but I'm still having the same problem. It is puzzling.

 

Hopefully, the new version will fix it.

 

 

Puzzling indeed.

 

Here is a working in progress for you to test: Evernote 5.5 beta

Share this post


Link to post

I've tried several times the Add to Evernote file action, but nothing happens. I must be doing something wrong. Any ideas?

 

Please, install the following version of the workflow: Evernote

 

This new version, that will be released soon, takes advantage of Alfred 2.0.3 (187) Apple Script improvements.

 

So, make sure to update Alfred then install the new workflow version.

 

Finally, make sure to update Evernote too or, if updated, try to restart it.

Share this post


Link to post

Hi there,

 

i am very much a newbie on everything mac. My rMBP arrived 3 hours ago, first thing i did was install Alfred because i've heard of it from OSX users before.

Now i found this awesome workflow.

Sadly, adding new notes doesn't work at all for me. Searching for Notes does work and the notes show up correctly.

If i add a new note via "ennew mynote" or "typenote mynote" - nothing happens and nothing new shows up in evernote.

 

Infos

- OSX 10.8.3

- Alfred 2.0.3

- Evernote Workflow 5.5 beta (i tried the latest stable before, which also didn't work) - i'm not sure if this is correct. I used the following version

Please, install the following version of the workflow: Evernote

 

I have no other workflows installed.

Any help is very appreciated!

Share this post


Link to post

Hi there,

 

i am very much a newbie on everything mac. My rMBP arrived 3 hours ago, first thing i did was install Alfred because i've heard of it from OSX users before.

Now i found this awesome workflow.

Sadly, adding new notes doesn't work at all for me. Searching for Notes does work and the notes show up correctly.

If i add a new note via "ennew mynote" or "typenote mynote" - nothing happens and nothing new shows up in evernote.

 

Infos

- OSX 10.8.3

- Alfred 2.0.3

- Evernote Workflow 5.5 beta (i tried the latest stable before, which also didn't work) - i'm not sure if this is correct. I used the following version

 

I have no other workflows installed.

Any help is very appreciated!

Hi,

 

First of all, congratulations for you new MacBook!

 

Now let’s try to see what is going wrong:

 

1. download this file and unzip it to your Desktop

2. you should see a file named en_addnote_test.scpt

3. now start the application AppleScript Editor (you can use Alfred or Spotlight to start it)

4. now open the file I sent you (while in the AppleScript Editor you can hit Command+O)

5. you should see something like this:

 

aseditor.png

 

6. Now click the button Run

7. This will try to create a note “test” in Evernote

8. You should see an error in some point: please take a screenshot or copy the error that will be displayed in Result

 

Every bit of information will help me to see why the workflow is not working in your system, though it is working in both my iMac and MacBook.

 

Thank you in advance.

Share this post


Link to post

thanks so much for the detailled HowTo (especially the key commands :-) )

This is the error i'm getting

 

error "„System Events“ hat einen Fehler erhalten: Der Zugriff für Hilfsgeräte ist deaktiviert." number -1719 from menu bar 1 of process "AppleScript Editor"

 

"Der Zugriff für Hilfsgeräte ist deaktiviert" is german for "access to help-devices(?) is deactivated".

I went straight to the system preferences and activated them - everything works like a charm now :-)

 

thanks so much! Great tool and workflow!

Edited by Sumit

Share this post


Link to post

thanks so much for the detailled HowTo (especially the key commands :-) )

This is the error i'm getting

 

 

"Der Zugriff für Hilfsgeräte ist deaktiviert" is german for "access to help-devices(?) is deactivated".

I went straight to the system preferences and activated them - everything works like a charm now :-)

 

thanks so much! Great tool and workflow!

 

Great to hear and thank you so much for the feedback! :)

 

PS: I’ll try to remove the part of the code that requires this preference

Edited by Carlos-Sz

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×