Jump to content

Recommended Posts

4 hours ago, biati said:

Other users have confirmed that this has been fixed


That's a bit puzzling as the latest release on Github is v4.0.5 and the version I have via the Gallery, and that is the one with the error, is also v4.0.5. 


4 hours ago, biati said:

If you need more help please create an issue on Github, I do not provide support here.


No worries, with an entered API key everything is fine. It is just that if no API key is provided, the warning message does not appear in Alfred, but rather, the workflow simply fails silently. 


The returned JSON should rather look something like this:


{"items":[{"title":"You need to configure the API key for Fixer","valid":false,"arg":""}]}


Edited by zeitlings
corrected json
Link to comment
4 minutes ago, vitor said:

Looking again at the output posted by @zeitlings, the JSON is indeed malformed. items should be an array of objects, not an object with a 0 key. arg shouldn’t be set and rerun should be a number, but those won’t stop the results from showing.

You may be getting more issues than normal because people are getting the message in the debugger but not in Alfred due to the malformed JSON.


Yes, something must be happening, not all users get that error, I'm able to see the error directly with Alfred about the API key. The workflow won't be receiving anymore updates in a while, I've a lot of work and don't have time, if anyone wants to open a PR that would be great.

Link to comment
4 minutes ago, zeitlings said:

The returned JSON should rather look something like this


That still errors out. It’s not the rerun causing the issue, but items not being an array.


Note I haven’t tested this in the workflow itself, I’m following the posted messages.

Link to comment

I recently updated from 4.0.2 to 4.0.5 and also didn't get any error saying my API key was missing. I was previously using a key for the service that was removed. 

Anyway, it's easily solved but was very annoying to waste time fixing what was already working. 

I'll try to find time to file a PR to fix the issue. 

Edited by gingerbeardman
Link to comment
  • 2 weeks later...

Hi :)

I am trying to use calculate anything.

I bought powerpack, used it a while, but something happened, I don't know the reason, and it stopped working.

I re-installed the Alfred, version 5.1.3.


I managed the dependency issue as below, installed php manually via terminal




but it does not work... how can I handle this issue?



Link to comment
On 10/24/2023 at 5:33 AM, vitor said:

Welcome @hoon,


As explained on the other thread, unless you post the debugger output we’re basically shooting in the dark. Help us help you.


Hi @vitor, I have the same problem as @hoon. I am on macOS Sonoma 14.0, and PHP in installed. Here's my Debugger log:



[10:45:41.242] Logging Started...
[10:45:51.012] Calculate Anything[Script Filter] Queuing argument ''
[10:45:51.121] Calculate Anything[Script Filter] Script with argv '(null)' finished
[10:45:51.124] ERROR: Calculate Anything[Script Filter] Code 6: dyld[47183]: Library not loaded: /usr/local/opt/libavif/lib/libavif.15.dylib
  Referenced from: <735019D8-AF6E-3CD1-9AD4-3BE47CB22D4F> /usr/local/Cellar/gd/2.3.3_5/lib/libgd.3.dylib
  Reason: tried: '/usr/local/opt/libavif/lib/libavif.15.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/usr/local/opt/libavif/lib/libavif.15.dylib' (no such file), '/usr/local/opt/libavif/lib/libavif.15.dylib' (no such file), '/usr/local/lib/libavif.15.dylib' (no such file), '/usr/lib/libavif.15.dylib' (no such file, not in dyld cache), '/usr/local/Cellar/libavif/1.0.1/lib/libavif.15.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/usr/local/Cellar/libavif/1.0.1/lib/libavif.15.dylib' (no such file), '/usr/local/Cellar/libavif/1.0.1/lib/libavif.15.dylib' (no such file), '/usr/local/lib/libavif.15.dylib' (no such file), '/usr/lib/libavif.15.dylib' (no such file, not in dyld cache)


Link to comment
  • 2 weeks later...
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...