Jump to content

I ran CleanMyMac and lost a load of functionality

Recommended Posts



I ran CleanMyMac after a recommendation from a friend, but I have now lost a lot of functionality.


I had to set up the clipboard history again, I am unable to search/open applications any more, all of my workflows are gone.


I am still able to find and locate files.


I don't expect these things can be restored, I think they have been wiped from the machine. 


But I don't know how to fix it. 


For example, I don't know how to get Alfred opening apps again, it also seems that I am unable to open apps with spotlight either.


Any help would be appreciated.


Thank you.

Link to comment
9 hours ago, goblbotch said:

it also seems that I am unable to open apps with spotlight either


It sounds like it has really screwed up your system. It might be that CleanMyMac deleted your Spotlight indexes, and Spotlight (and Alfred) will start finding things again when macOS has finished re-indexing everything. If you actually disabled indexing, then it won't.


I'd expect a program like CleanMyMac to delete all your workflows' cached data, but it shouldn't have touched the workflows themselves.


You really need to be talking to whoever wrote the software that has messed up your system.

Link to comment

Do you have a recent backup of your system? It sounds as though it's not merely Alfred that's affected so it might be better to restore the system from a recent backup.


In passing, I dislike apps like the one you mention and think they do more harm than good. I'm sorry that you've found that out the hard way and hope you can find some way of recovering what you need.



Link to comment

CleanMyMac is particularly aggressive. It considers universal binaries “system junk” and offers to strip the part not appropriate for your current architecture, breaking apps in the process. For future reference, consider /System/Library/CoreServices/Applications/Storage Management.app as a more manual way of finding what’s eating up your disk space.

Didn’t you by any change setup Alfred’s Syncing? If so, even if your Workflows were deleted you might be able to recover them as some services (like Dropbox) allow you to restore deleted files.

Link to comment
  • 10 months later...

I currently have the same problem as well, I've downloaded the app and used it and all my alfred files are gone. 


Is there a way (without backing up the whole system) that would allow me to restore:

  1. Workflows
  2. Snippets

I'm really hoping everything is going to be fine... :(

Link to comment

@SK. Apps like Clean My Mac are quite aggressive in deleting essential files.


First, check your Mac's Trash, in case that's where the "cleaned" files are moved to. If you find your Alfred.alfredpreferences, keep this file safely and we'll help you reset it.


Do you use Time Machine? If so, you should be able to recover your files there.


Please provide more details on your setup and I'll help you recover what can be recovered.

Link to comment
  • 11 months later...



Is there a solution that anyone knows about to prevent this from happening in future CleanMyMac scans? I have copies of my alfred preference which i can go back to whenever It happens. But it would be ideal if there is a solution to either move my alfred preferences to a place where CleanMyMac can't touch or if there are settings on CleanMyMac that can stop it from clearing the Alfred preferences.



Link to comment

I had a similar problem with another app.

And people have reported it happened after a CleanMyMac run.

They're support recommend to exclude your app which you need to avoid this happening.


TimeMachine has 'saved my day' several times.

with best regards,
Omar KN, Stockholm, Sweden

Edited by OmarKN
Link to comment



I reached out to cleanmymac and they told me to do what @OmarKN mentioned.



Thank you for contacting MacPaw Customer Support.
Note that you can always add the apps and their related folder to the ignore list, so that CleanMyMac X will not take them into account for the next scans. To do that, follow the steps below:


Link to comment
  • 1 year later...

Same problem here. I recently downloaded CleanMyMac but it mucked up my Microsoft Office 11 software (purchased with my Mac 11 years ago)

Now I don't have access to any of my files.  Word, Excel, Powerpoint, etc...

The Excel icon has completely disappeared.

What can I do to fix this?

I also cannot back up as ICloud doesnt seem to work and I don't have compatible drive with TimeMachine.

If I can find my original disks for Office, can I just reinstall the old office? 

I am not sure what else to do.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...