Jump to content

Spotify Mini Player: Control your Spotify library at your fingertips


Recommended Posts

On 12/3/2023 at 9:56 AM, boixos24 said:

This is an incredible piece of software and want to thank the creator for developing it. Thank you.

 

However, I'm having an issuing with the lyrics. For a lot of songs, I keep getting "No lyrics found" despite the lyrics clearly being there on Spotify:

 

CleanShot2023-12-03at10_07_07@2x.thumb.png.f9363cd58ef3cb97d3df8f1f81997e6b.png

CleanShot2023-12-03at10_12.59@2x.thumb.png.348b8999db1b4ed041bdd617ee786401.png

Lyrics are clearly visible in the Spotify app yet I get "No lyrics found" a lot of the time for many songs

 

Also, is there a way to search for lyrics online if they're NOT available on Spotify?

 

 

Spotify api does not provide lyrics, so I'm using best effort search in musixmatch

 

I'll add online search in 13.2, see https://github.com/vdesabou/alfred-spotify-mini-player/issues/620

Link to comment
  • 2 months later...

I really like the Spotify Mini Player workflow and use it all the time. However, I had to reinstall everything recently and I'm now running into two problems.

 

The first is that I used to be able to search for a song, hit enter and it would play without then automatically re-opening the Spotify window. Now it opens every time. How do I stop this happening?

 

The second is that the artwork download has been "in progress" for about three weeks. Are there any ways to sort this?

 

Many thanks.

Screenshot 2024-02-08 at 11.48.21.png

Link to comment

@porcupine945 When asking about an existing Workflow, it’s best to use its own forum thread. While it may seem that starting a new thread could give your problem visibility, it fragments the discussion and makes it less likely the author and users of the workflow (the people who can help) will see it. I’ve moved your post to the correct thread.

Link to comment
8 minutes ago, vitor said:

@porcupine945 When asking about an existing Workflow, it’s best to use its own forum thread. While it may seem that starting a new thread could give your problem visibility, it fragments the discussion and makes it less likely the author and users of the workflow (the people who can help) will see it. I’ve moved your post to the correct thread.


Thanks and apologies - I’m new here and didn’t know that there was such a thing.

Link to comment
On 2/8/2024 at 12:50 PM, porcupine945 said:

 

The first is that I used to be able to search for a song, hit enter and it would play without then automatically re-opening the Spotify window. Now it opens every time. How do I stop this happening?

 

This should not happen. I've a user reporting this once and that was fixed by a reboot

 

 

On 2/8/2024 at 12:50 PM, porcupine945 said:

 

The second is that the artwork download has been "in progress" for about three weeks. Are there any ways to sort this?

 

Many thanks.

Screenshot 2024-02-08 at 11.48.21.png

 

Use this command to kill it

 

CleanShot2024-02-10at09_47.30@2x.jpg.4fc94cf6ea64ae33466900286c65f87f.jpg

 

 

 

Link to comment
  • 2 weeks later...

Hi,

 

Is there a way to not launch the Spotify window when I choose a playlist to play through Alfred? Each time I do, it brings Spotify window as frontmost app and then plays the playlist. Is this something that can be changed so the Spotify GUI stays hidden all the time?

Link to comment
8 hours ago, Kamil said:

Hi,

 

Is there a way to not launch the Spotify window when I choose a playlist to play through Alfred? Each time I do, it brings Spotify window as frontmost app and then plays the playlist. Is this something that can be changed so the Spotify GUI stays hidden all the time?

 

Few users have reported this but I'm unable to reproduce the issue.

 

Are you using Spotify Connect or Spotify Desktop ? https://alfred-spotify-mini-player.com/articles/spotify-connect/

 

If using Spotify Desktop, the workflow uses applescript to launch commands, but in any case, it does not call "activate" (unless for specific commands like):

 

CleanShot2024-02-22at15_44_52.jpg.74e2c9e3203545e7d6be299a244aa7da.jpg

 

So if that happens, this is likely a spotify or applescript bug, not a workflow bug.

 

I've seen once a user that got it fixed by rebooting the mac for example...

 

Unfortunately, I don't think I can do much more here.

Link to comment
  • 2 weeks later...
On 2/22/2024 at 3:46 PM, vdesabou said:

 

Few users have reported this but I'm unable to reproduce the issue.

 

Are you using Spotify Connect or Spotify Desktop ? https://alfred-spotify-mini-player.com/articles/spotify-connect/

 

If using Spotify Desktop, the workflow uses applescript to launch commands, but in any case, it does not call "activate" (unless for specific commands like):

 

CleanShot2024-02-22at15_44_52.jpg.74e2c9e3203545e7d6be299a244aa7da.jpg

 

So if that happens, this is likely a spotify or applescript bug, not a workflow bug.

 

I've seen once a user that got it fixed by rebooting the mac for example...

 

Unfortunately, I don't think I can do much more here.

I've followed all your recommendations and made sure that the issue is not on Spotify side. All configurations, plists and caches were cleared, and a fresh app install made. I can only think of re-installing workflow itself as the next logical troubleshooting step. Alfred debugging didn't give much anything relevant to my issue and PHP is up-to-date.

 

Is there something you could recommend to help?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...