Jump to content

Fakeum — Generate fake test datasets in Alfred

Recommended Posts


Generate fake test data in Alfred for testing.



Get the workflow from GitHub.


  • fake [<query>] — List/filter available fake data types
    • , ⌘+C or ⌘+NUM — Copy one fake datum to clipboard
    • ⌘+↩ — Paste fake datum into frontmost app
    • — Specify number of datasets to copy to clipboard
    • ⌘+L — Show generated data in Alfred's Large Text window
  • fakeconfig [<query>] — Activate and deactivate locales for fake data
    • — Toggle selected locale on or off

If you specify multiple data, e.g. fake Name 〉 10 for 10 names, the data
will be separated by newlines (\n).

In the case of Paragraph and Address types, the data will be separated
by two newlines (\n\n).

Supported data types and locales

See the GitHub page for details.

Edited by deanishe
Remove Packal link
Link to comment

The ⇥ action is built in to Alfred. It shouldn't highlight anything, and the workflow can't affect its the way it works, AFAIK.
Could you enter fake catch in Alfred's query box and tell me what Alfred shows in its results list and also in the debugger?

Link to comment
  • 3 weeks later...
  • 1 year later...
  • 1 year later...
4 hours ago, 40-02 said:

But now I have a problem - that python process hangs up. Many python processes had heavy CPU usage. 

Tried this workflow https://github.com/deanishe/alfred-fixum/

But it doesn't help. 


No, Fixum won't help because it has the same version of the library. This isn't that bug.


I can't get the workflow to misbehave in that way. Could you kill the offending Python processes and see if it happens again?


Also, which version of macOS are you running?

Link to comment
On 03/12/2017 at 1:49 PM, deanishe said:

I can't get the workflow to misbehave in that way. Could you kill the offending Python processes and see if it happens again?


Also, which version of macOS are you running?



I killed python process and when I tried to use today's fakeum again - everything repeated. 

My OS is High Sierra 10.13.1 (the latest one). 

I'm one of those users who try to tweak their computer in many ways, even if they don't understand what exactly they do. So, I might mess up with python by myself. And maybe my problem is very specific:(

Link to comment
22 minutes ago, 40-02 said:

And maybe my problem is very specific:(


It sounds like a re-occurence of the Sierra bug. I did change that section of the code in the latest release of Alfred-Workflow (which Fakeum uses).


I haven't had any issues on El Cap or Sierra, but I don't have High Sierra to test it on (and I'm not going to install it, as it's still rotten with bugs).


At this point, I'd like to wait and see if anybody else is having the same issue (which should soon become apparent, as Fixum—the workflow that fixes the Sierra bug—also installs the latest version of Alfred-Workflow). If they are, I'll back out the changes to the forking code.

Link to comment
  • 1 year later...
  • 2 years later...



I am sorry but "newbie in progress"…


I have just installed Fakeum on my newly installed AlfredApp (on a totally new MacBook Pro M1 - MacOS Monterey).

Fakeum seems to be correctly installed on Alfred (Present in "workflows")…


…but I can't succeed to generate any fake data. 

I am a little bit lost…


Any help would be most welcome.


Very best



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...