Jump to content
Carlos-Sz

Evernote Workflow 9 beta 4 (Alfred 4)

Recommended Posts

Is there a way to open a new note IN EVERNOTE (and have the window open up and start typing there)?

 

Sorry if I'm not using this right, but it seems like all the ENN options create the note directly in the Alfred window. I'd like to be able to just open up evernote with a new note being created.  

 

(And I could make my own one workflow -with some guidance)

 

Thanks.

Share this post


Link to post

Looks as though this workflow breaks with the new 6.11 (beta 1) release. Bummer as I'm so dependent on this workflow every day. May have to restore an earlier version of EN if you don't have a quick fix. :-(

Share this post


Link to post
On 2017-01-02 at 4:31 PM, rr326 said:

Is there a way to open a new note IN EVERNOTE (and have the window open up and start typing there)?

 

Sorry if I'm not using this right, but it seems like all the ENN options create the note directly in the Alfred window. I'd like to be able to just open up evernote with a new note being created.  

 

(And I could make my own one workflow -with some guidance)

 

Thanks.

 

1. Activate Alfred preferences

2. Go to "Workflows" tab

3. Click the "+" sign at the lower left corner

4. Select "blank workflow"

5. Right click to add a workflow object 

6. Select trigger -> hotkey

7. Assign hotkey

8. Right click again to add an action

9. Select action -> run NSAppleScript

10. Add the code below

activate application "Evernote"

tell application "System Events"

    keystroke "n" using {command down}

end tell

11. Connect the hotkey and action by dragging a line between them

12. Trigger the hotkey to activate the script

 

Not sure if this is what you wanted but perhaps you can work your way from here. 

Edited by Compton

Share this post


Link to post
On 1/6/2017 at 11:59 AM, mboettger1 said:

Looks as though this workflow breaks with the new 6.11 (beta 1) release. Bummer as I'm so dependent on this workflow every day. May have to restore an earlier version of EN if you don't have a quick fix. :-(

 

Doesn't seem to work on Evernote 6.10 either non-MAS store version - here anyway. Did you have any luck getting it to work?

Share this post


Link to post

@patgilmour @mboettger1 Could you guys give an example of what's not working for you?

 

I'm using Evernote 6.10 and everything I've tried seems to work as expected, so if you could provide more details, we should be able to help troubleshoot. If there are any legitimate issues, we can ping the wonderful creator of this workflow for a bit of help :)

 

Cheers,
Vero

Share this post


Link to post
38 minutes ago, Vero said:

@patgilmour @mboettger1 Could you guys give an example of what's not working for you?

 

I'm using Evernote 6.10 and everything I've tried seems to work as expected, so if you could provide more details, we should be able to help troubleshoot. If there are any legitimate issues, we can ping the wonderful creator of this workflow for a bit of help :)

 

Cheers,
Vero

Hi Vero

 

same here .. actually a crash with possibility to send a report.

Symptoms:

- do not matter if evernote was opened before or not the application simply crashes (OS X10.12.2 - evernote 6.11 beta 1)

- if Evernote was closed the plugin opens the app but crashes immediately upon starting

 

 

Share this post


Link to post

@M0ll3art Thanks for your post. Could you please add your Powerpack email address to your forum profile? It's only visible to administrators and allows us to confirm your Powerpack status. :)

 

Cheers,
Vero

Share this post


Link to post
16 hours ago, Vero said:

@patgilmour @mboettger1 Could you guys give an example of what's not working for you?

 

I'm using Evernote 6.10 and everything I've tried seems to work as expected, so if you could provide more details, we should be able to help troubleshoot. If there are any legitimate issues, we can ping the wonderful creator of this workflow for a bit of help :)

 

Cheers,
Vero

Hi Vero, 

 

So by not working what I mean is, if I try to invoke, say, the Evernote search 'ens' (Script filter in the flow) the only option that appears is "Synchronize Evernote". I tried putting a keyboard shortcut up front (ctrl+J) - when I press this, I see Evernote Searching... for about 1/3 second, then Alfred jumps straight to my fallback searches (Google, Wiki, Facebook).

 

I suspect this might be something to do with the way I have the flow or Alfred configured, but I don't know what it is.

 

Thanks,

 

Pat

keyboard.png

Share this post


Link to post

@patgilmour Have you ever successfully seen results appear for Evernote with previous versions? Or is this the first time you use the workflow at all?

 

When I use the "ens" keyword, Evernote first launches in the background. Once launched, the "ens" keyword shows "Show in Evernote" and the titles of the latest 8 entries I've added/modified in Evernote before typing any further to filter my notes.

 

Even if I type "ens aiowghohoa" so that no results are found, I see the "No results" message from the workflow and never fall back to Alfred's default searches. 

 

Screen Shot 2017-01-10 at 09.45.44.png

 

As you're getting a different behaviour, could you please delete the workflow and re-download it from the first page of this thread?

 

Also please check Evernote to be 100% sure you're using the correct version; It should say "Direct" under "About Evernote".

 

Screen Shot 2017-01-10 at 09.44.47.png

 

Cheers,

Vero

Share this post


Link to post

As mboettger1 mentioned above the workflow does not work with Version: 6.11 Beta 1 (454536).

 

Unfortunately, the new Evernote update (tabs feature) breaks it and Evernote crashes as soon as the workflow is executed. When this moves on from beta it will presumably break for everyone. 

 

If you could give the developer a gentle nudge that would be appreciated as this workflow is amazing and has really helped me.

 

Thanks a lot.

Share this post


Link to post
On 1/10/2017 at 5:46 AM, Vero said:

I'm not sure the issue @patgilmour is seeing is related, so we can likely still get to the bottom of that.

 

Hi,

 

So I'm running: Version 6.10 (454267 Direct)

 

Basically when I invoke Evernote Search via the Workflow, it bounces me to my Alfred default searches.

 

Alfred can access Evernote through its own search though, as I added  `/Users/work/Library/CoreData/com.evernote.Evernote` to the default Search Scope. This works, but only searches on title, not content.

 

Thanks,

 

Pat

 

Share this post


Link to post

@patgilmour Do any of the other Evernote workflow keywords work for you?

 

- Does "ent" allow you to search by titles?

- Does "enrec" show you a list of your recent Evernote notes? (provided you've created/added some in the past few days)

- Does "enn" allow you to create a new note?

 

It'd be helpful to understand how much does and doesn't work for you. If you could provide as much details as you can, it'll be easier to help you troubleshoot the issue.

 

Cheers,
Vero

 

Share this post


Link to post
7 hours ago, Vero said:

@patgilmour Do any of the other Evernote workflow keywords work for you?

 

- Does "ent" allow you to search by titles?

- Does "enrec" show you a list of your recent Evernote notes? (provided you've created/added some in the past few days)

- Does "enn" allow you to create a new note?

 

It'd be helpful to understand how much does and doesn't work for you. If you could provide as much details as you can, it'll be easier to help you troubleshoot the issue.

 

Cheers,
Vero

 

Hi Vero,

 

I uninstalled, quit, restarted, reinstalled from link on page one here – now everything is working!

 

Thanks for taking the time to try to help me sort this out!

 

Pat

Share this post


Link to post
On 1/12/2017 at 3:57 AM, Vero said:

@patgilmour Do any of the other Evernote workflow keywords work for you?

 

- Does "ent" allow you to search by titles?

- Does "enrec" show you a list of your recent Evernote notes? (provided you've created/added some in the past few days)

- Does "enn" allow you to create a new note?

 

It'd be helpful to understand how much does and doesn't work for you. If you could provide as much details as you can, it'll be easier to help you troubleshoot the issue.

 

Cheers,
Vero

 

Hi, @Vero I'm having similar problems since upgrading to Alfred 3. I used to be able to use the workflow, but now, after initializing the hot keys (for example, "ent") I see the option to search my Evernote Titles, but when I hit Tab or Enter (which used to take me to the next stage, entering a title of a note), it just defaults me to Google Search in Alfred. Here's an example of my attempt to search to-dos. 

 

One thing to note... On one of my Macs, the Evernote workflow works perfectly. But on a different Mac, it performs as described above. 

 

 

Overlay.png

Edited by pedantix

Share this post


Link to post
On 1/12/2017 at 11:44 AM, patgilmour said:

Hi Vero,

 

I uninstalled, quit, restarted, reinstalled from link on page one here – now everything is working!

 

Thanks for taking the time to try to help me sort this out!

 

Pat

@patgilmour Can you explain what you uninstalled, quit, restarted, reinstalled from link on page one here? I will try to replicate your steps. Thanks!

Share this post


Link to post

@pedantix Could you please fill in your valid Powerpack email address in your forum profile? I can see you've entered an email address but this doesn't relate to a registered Powerpack license in our system. As soon as you've updated this, I'll be happy to help!

 

Drop me a private message if you need any help updating this. :)

 

Cheers,
Vero

Share this post


Link to post

Evernote 6.10: make sure to download from Evernote site (not from AppStore) and if the workflow is not working try to uninstall if from Alfred preferences then download the latest version of the workflow and install it again.

 

Evernote 6.11 beta: I'll have to wait a final version

 

 

Share this post


Link to post
2 hours ago, Carlos-Sz said:

Evernote 6.10: make sure to download from Evernote site (not from AppStore) and if the workflow is not working try to uninstall if from Alfred preferences then download the latest version of the workflow and install it again.

 

Evernote 6.11 beta: I'll have to wait a final version

 

 

@Carlos-SzThank you! Deleted Evernote from the app store, downloaded Evernote from Evernote.com, deleted the Workflow from Alfred, reinstalled, and we're back in business! Thank you so much, and thank you, @Vero, for getting back to me. I super appreciate this workflow. 

Share this post


Link to post
16 hours ago, pedantix said:

@patgilmour Can you explain what you uninstalled, quit, restarted, reinstalled from link on page one here? I will try to replicate your steps. Thanks!

Hi @pedantix - I uninstalled the Alfred Evernote Workflow, quit Evernote & Alfred, relaunched Alfred, installed the flow from the top of this forum thread, and that was it!

-Pat

Share this post


Link to post

I love this workflow and cannot live without it.  Recently, I upgraded Alfred to v3 and now it's having some issue. I often use "ent" to search notes by keywords in title. In the past, "ent set" will match title "mac setup", but now, it will not. I have to type out "ent setup" then the result will show up. Looks like we no longer do partial match for a word?

 

Thanks!

Share this post


Link to post

@Shuyi Could you clarify; Can you get results for any of the Evernote workflow keywords, or none at all?

 

Check the first post in this thread and ensure that you're using:

- Alfred 3.3.1

- Evernote 6+ from Evernote.com (not from the Mac App Store

- The latest version of the workflow from the first post of this thread?

 

If you're using the up to date version of all three, the workflow should work great for you :)

 

Cheers,
Vero

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...