Jump to content

Mail Actions Workflow [Updated v0.7]


Recommended Posts

Hi,

 

Is it possible to add a shortcut key to focus the body section of the compose window?

 

Thanks,

matt

I'll look into it, but I'm not too sure it's possible with AppleScript. Maybe Keyboard Maestro could easily do the trick. (Come to think about it, it's also something that nothers me from time to time, so I?ll definitely look into it) ;)

Link to post
  • 3 weeks later...
  • Replies 114
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Introducing Mail Actions   Go crazy minimal with Mail.app and still stay functional thanks to the power of Alfred 2 Workflows. See it in Action here Features Use Alfred to: Navigate Mailboxes fr

Hot damn. I just wish this had come along before I bought MailHub!

What's this??? Is that the unread count I see?   Yeah, I know, lot's to read, no time to do so...

Very cool, thanks for this great workflow!

To make it perfect, please consider to add the following function (as previously mentioned by LeChuck):

 

- Support of smart mailboxes. Currently, they don't seem to be supported.

Hi,

 

Currently there seems to be no way of exposing Smart Mailboxes with AppleScript so I can't really help there.

Link to post

Hi Pedro,

 

nice script, thanks a lot for your work and sharing it!

 

Just fyi: I'm running 10.9. GM and there is a bug with Umlauts in mailbox folder names. I had one named "Büro" and this breaks the script: 

 

"getList.scpt: execution error: Mail got an error: Can’t get mailbox "INBOX/Büro/_archiv" of account "xxxxx". (-1728)"

 

I'm pretty sure if this error remains in the final seed, you'll get a couple of replies about that.

 

A workaround is to make sure that there are no mailboxes and mailbox folders with special characters and umlauts. Another would probably be to catch this error on your side and exit gracefully with some sort of hint or display.

 

Best,

Michael

Edited by auco
Link to post

Hi Pedro,

 

nice script, thanks a lot for your work and sharing it!

 

Just fyi: I'm running 10.9. GM and there is a bug with Umlauts in mailbox folder names. I had one named "Büro" and this breaks the script: 

 

"getList.scpt: execution error: Mail got an error: Can’t get mailbox "INBOX/Büro/_archiv" of account "xxxxx". (-1728)"

 

I'm pretty sure if this error remains in the final seed, you'll get a couple of replies about that.

 

A workaround is to make sure that there are no mailboxes and mailbox folders with special characters and umlauts. Another would probably be to catch this error on your side and exit gracefully with some sort of hint or display.

 

Best,

Michael

Hi Michael.

 

Thanks for the update on this. I haven't gotten my hands on 10.9 yet so couldn't test it yet. I'll be sure to look into this when I've got Mavericks.

 

Cheer,

Pedro

Link to post
  • 4 weeks later...

 

I am trying to optimize the list of all mailboxes and looked into the Workflow Data folder and nothing is in the folder. Anyone have any ideas why Alfred would not create these files? 

com.palobo.mailactions/mbCache.plist

HI,

 

Have you updated to Mavericks? Could be something  wrong with due to that. As soon as I have a little more time I intend to fully rewrite this workflow in a more optimised way with newer features too.

Link to post

HI,

 

Have you updated to Mavericks? Could be something  wrong with due to that. As soon as I have a little more time I intend to fully rewrite this workflow in a more optimised way with newer features too.

 

Hi Pedro,

 

Yes I have updated to Mavericks. So for now I will just wait until there is an updated posted. Thank you.

Link to post
  • 2 months later...
  • 8 months later...
  • 3 years later...

Are others having problems moving messages in High Sierra?

 

When using "mm" to move an email to a specific folder, the workflow appears to work perfectly: I get a notice that the email has moved, and it disappears from the folder. When I refresh the mailbox or Quit and Re-open Mail, however, these messages always come back. The message will be located in its original folder, but a copy of the message will be located in the mailbox where it was moved. To be clear, I'm not accidentally using the alternative copy option either.

 

Has anybody else experienced this issue? If so, how'd you fix it? Thanks for your help!

Link to post
  • 1 month later...

@palobo By chance, did you get a chance to look at the MM (move mail) function in your Mail Actions workflow (see quote below)?

 

I was never able to get it working again. The workflow always looks like its working perfectly, but when I navigate out of the folder where the message was moved from and reopen it, the message is always still there. It looks like it may just be copying the message over to the new location. 

 

Thanks in advance for any help you can lend!

 

On 11/8/2017 at 5:16 PM, Jasondm007 said:

Are others having problems moving messages in High Sierra?

 

When using "mm" to move an email to a specificfolder, the workflow appears to work perfectly: I get a notice that the email has moved, and it disappears from the folder. When I refresh the mailbox or Quit and Re-open Mail, however, these messages always come back. The message will be located in its original folder, but a copy of the message will be located in the mailbox where it was moved. To be clear, I'm not accidentally using the alternative copy option either.

 

Has anybody else experienced this issue? If so, how'd you fix it? Thanks for your help!

1

 

Link to post
  • 1 year later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...