Jump to content
vdesabou

Spotify Mini Player: Control your Spotify library at your fingertips

Recommended Posts

Hi I'm having a problem with this. I recently updated to version 3 and actually tried to update my library. I've been waiting for more than 24 hours and the library is still updating. how can I stop the update and redo the library scan?

Share this post


Link to post

Hi I'm having a problem with this. I recently updated to version 3 and actually tried to update my library. I've been waiting for more than 24 hours and the library is still updating. how can I stop the update and redo the library scan?

 

Hi, to force stop the update, remove the file "update_library_in_progress" in /Users/YOUR_USER/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/update_library_in_progress

 

Then I suggest that you:

 

-delete /Users/YOUR_USER/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/library.db

-delete /Users/YOUR_USER/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/settings.db

-re-download and install workflow here Download Workflow

-create your library

 

Depending on the number of playlists you're using, it may take time, to give you an idea I have 3100 tracks in my library, it takes about 10 minutes to create the library (but the very first time it takes more time as all the artworks are downloaded)

If you experience same issue with never-ending library creation: 

-then type "spot_mini_debug" command and you should have a spot_mini_debug.tgz file in your Downloads directory. Send it to me.

 

Cheers

Share this post


Link to post

I've just updated to version 3.1, UPDATE YOUR LIBRARY!!!
 
3.1:

  • Moving to spotify API 1.x: no more 200 tracks limitation on playlists
  • Added spot_mini_debug command to help troubleshooting
  • Improved robustness and error detections

Download Workflow

Edited by vdesabou

Share this post


Link to post

I do not get any JSON-Output. I don't get an error either. Do you have any idea what the problem is? I am stuck at the following screen: 4c0w.png

Edited by 0x6368

Share this post


Link to post

I do not get any JSON-Output. I don't get an error either. Do you have any idea what the problem is? I am stuck at the following screen: 4c0w.png

 

Hi, 

 

Hum, there must be something wrong when doing the export.

 

Can you, once you have clicked the Export as JSON button, open the debug console. In Spotify, type "alt-cmd-J", or go in Development->See inspector

 

And then you should see a console like this:

 

gtQf+.png

Share this post


Link to post

Cool, I didn't know there is a debug console :)

 

I debugged it a bit a found out, that snapshots.length (miniplayer.js line 269) equals 8, but snapshots.get(7) (miniplayer.js line 271) is null, so line 288 is never called. Any idea why it is null?

Share this post


Link to post

Cool, I didn't know there is a debug console :)

 

I debugged it a bit a found out, that snapshots.length (miniplayer.js line 269) equals 8, but snapshots.get(7) (miniplayer.js line 271) is null, so line 288 is never called. Any idea why it is null?

 

Thanks for debugging this!

 

I think I understand why, I've reproduced by adding a folder at the end of my playlists, see "test" folder:

 

Juub+.png

 

Can you confirm it is your case?

I'll provide a fix shortly

Share this post


Link to post

Thanks for debugging this!

 

I think I understand why, I've reproduced by adding a folder at the end of my playlists, see "test" folder:

 

Juub+.png

 

Can you confirm it is your case?

I'll provide a fix shortly

Yea, I have got a folder at the end of my playlist. Thank you! Awesome support! :-)

 

BTW: I like your musical taste, Bon Iver is great!

Share this post


Link to post

Yea, I have got a folder at the end of my playlist. Thank you! Awesome support! :-)

 

BTW: I like your musical taste, Bon Iver is great!

 

thanks :)

 

Can you re-download the workflow, I have updated it with a fix.

-Delete the ~/Spotify/spotify-app-miniplayer folder to force the fix to be installed.

-You may have also to restart Spotify to make sure the latest version is used.

 

Let me know if this fixes the problem

Share this post


Link to post

thanks :)

 

Can you re-download the workflow, I have updated it with a fix.

-Delete the ~/Spotify/spotify-app-miniplayer folder to force the fix to be installed.

-You may have also to restart Spotify to make sure the latest version is used.

 

Let me know if this fixes the problem

Does still not work. Line 306 is false, because array_results.length equals 6 and matchedPlaylists.length equals 7.

Share this post


Link to post

Does still not work. Line 306 is false, because array_results.length equals 6 and matchedPlaylists.length equals 7.

 

mmm, so I guess line 247 is not executed for one your playlists:

 

if(snapshot.length == array_tracks.length)

 

Can you add a console.log like this and see which playlist is causing issue:

 

console.log(snapshot.length,array_tracks);

if(snapshot.length == array_tracks.length)
 
Otherwise, maybe you can share temporarily all your playlists, so that I can subscribe to them and see if I can reproduce?

Share this post


Link to post

No more need to copy the JSON data, now the install/update library is even more easy !!!
 
 
3.2:

  • No more need to copy JSON data! Just click on "Update library"
  • Added spot_mini_kill command to kill update library if it is stuck

Download Workflow

Share this post


Link to post

I added the line

 

console.log(snapshot.length,array_tracks);

 

But it seems that every playlist is added. I get the following output:

getPlaylists finished 
[Object, Object, Object, Object, Object, Object, Object]

111 1
111 2
111 3
111 4
111 5
111 6
111 7
111 8
111 9
111 10
111 11
111 12
111 13
111 14
111 15
111 16
111 17
111 18
111 19
111 20
111 21
111 22
111 23
111 24
111 25
111 26
111 27
111 28
111 29
111 30
111 31
111 32
111 33
111 34
111 35
111 36
111 37
111 38
111 39
111 40
111 41
111 42
111 43
111 44
111 45
111 46
111 47
111 48
111 49
111 50
111 51
111 52
111 53
111 54
111 55
111 56
111 57
111 58
111 59
111 60
111 61
111 62
111 63
111 64
111 65
111 66
111 67
111 68
111 69
111 70
111 71
111 72
111 73
111 74
111 75
111 76
111 77
111 78
111 79
111 80
111 81
111 82
111 83
111 84
111 85
111 86
111 87
111 88
111 89
111 90
111 91
111 92
111 93
111 94
111 95
111 96
111 97
111 98
111 99
111 100
111 101
111 102
111 103
111 104
111 105
111 106
111 107
111 108
111 109
111 110
111 111
22 1
22 2
22 3
22 4
22 5
22 6
22 7
22 8
22 9
22 10
22 11
22 12
22 13
22 14
22 15
22 16
22 17
22 18
22 19
22 20
22 21
22 22
1 1
127 1
127 2
127 3
127 4
127 5
127 6
127 7
127 8
127 9
127 10
127 11
127 12
127 13
127 14
127 15
127 16
127 17
127 18
127 19
127 20
127 21
127 22
127 23
127 24
127 25
127 26
127 27
127 28
127 29
127 30
127 31
127 32
127 33
127 34
127 35
127 36
127 37
127 38
127 39
127 40
127 41
127 42
127 43
127 44
127 45
127 46
127 47
127 48
127 49
127 50
127 51
127 52
127 53
127 54
127 55
127 56
127 57
127 58
127 59
127 60
127 61
127 62
127 63
127 64
127 65
127 66
127 67
127 68
127 69
127 70
127 71
127 72
127 73
127 74
127 75
127 76
127 77
127 78
127 79
127 80
127 81
127 82
127 83
127 84
127 85
127 86
127 87
127 88
127 89
127 90
127 91
127 92
127 93
127 94
127 95
127 96
127 97
127 98
127 99
127 100
127 101
127 102
127 103
127 104
127 105
127 106
127 107
127 108
127 109
127 110
127 111
127 112
127 113
127 114
127 115
127 116
127 117
127 118
127 119
127 120
127 121
127 122
127 123
127 124
127 125
127 126
127 127
3 1
3 2
3 3
2 1
2 2

Share this post


Link to post

 

I added the line

 

console.log(snapshot.length,array_tracks);

 

But it seems that every playlist is added. I get the following output

 

Do you have a playlist that is empty, with no songs ?

When I create it one, I reproduce your issue

Share this post


Link to post

Do you have a playlist that is empty, with no songs ?

When I create it one, I reproduce your issue

 

Can you re-download the workflow, I fixed this empty playlist issue (if you confirm you have one).

 

Otherwise, can you give me more info on the missing playlist?

Share this post


Link to post

I already tried version 2.0; I still don't get a message that the library was installed even though I don't have an empty playlist. But I think I know where the problem is.

 

It looks like you iterate iTunes playlists as well. In iTunes I have a playlist with an audio stream (URL: http://mp3stream1.apasf.apa.at:8000/). Maybe you can access the playlist with the URI: spotify:user:@:playlist:54TRqJcX15CifJyeEhLq8G

Edited by 0x6368

Share this post


Link to post

I already tried version 2.0; I still don't get a message that the library was installed even though I don't have an empty playlist. But I think I know where the problem is.

 

It looks like you iterate iTunes playlists as well. In iTunes I have a playlist with an audio stream (URL: http://mp3stream1.apasf.apa.at:8000/). Maybe you can access the playlist with the URI: spotify:user:@:playlist:54TRqJcX15CifJyeEhLq8G

 

Hum, I'm not sure to understand. I added your stream into an iTunes Playlist but I'm not sure how it would impact Spotify..

I don't iterate over iTunes playlists. Can you provide more details? Does this stream appear in Spotify ?

Can you show a screenshot of the Spotify console when the problem happens?

 

Thanks

Share this post


Link to post

Okay, I think I actually found the problem now. The iTunes playlists that were listed in the output were in the playlist folder "iTunes". If I delete the empty playlist "FM4" at the end of the folder, I get the JSON-Code. If the playlist is at the end of the folder, I don't get the JSON-Code.

 

Hope this helps! :-)

 

Edit: I get the JSON-Code now, but I still don't get a notification that the library is installed and I still see the "Install Library" entry.

This is my console output:

dx8.png

Edited by 0x6368

Share this post


Link to post

Okay, I think I actually found the problem now. The iTunes playlists that were listed in the output were in the playlist folder "iTunes". If I delete the empty playlist "FM4" at the end of the folder, I get the JSON-Code. If the playlist is at the end of the folder, I don't get the JSON-Code.

 

Hope this helps! :-)

 

 

 

Edit: I get the JSON-Code now, but I still don't get a notification that the library is installed and I still see the "Install Library" entry.

This is my console output:

dx8.png

 

So did you remove the empty playlist finally? Because I can't reproduce on my side with this:

 

QUJN+.png

 

 

When you execute "spot_mini" again, do you see a warning message saying that library is in progress?

 

Also, if you can open a terminal and type the two commands:

 

 

 

ps -efx | grep php
 
and
 
netstat -an | grep 17693
 
Also, can you execute "spot_mini_debug" and provide the tgz file that would be generated in your download folder?
 
Thanks for your help

Share this post


Link to post

 

So did you remove the empty playlist finally? Because I can't reproduce on my side with this:

 

QUJN+.png

 

 

When you execute "spot_mini" again, do you see a warning message saying that library is in progress?

 

Also, if you can open a terminal and type the two commands:

 

 

 

ps -efx | grep php
 
and
 
netstat -an | grep 17693
 
Also, can you execute "spot_mini_debug" and provide the tgz file that would be generated in your download folder?
 
Thanks for your help

 

After I executed the two terminal commands, I got the warning message that library is in progress (don't know if it worked before), but it did not end. So I killed it and it seems to work now.

 

Sent you a pm on last.fm (didn't find the button here xD) with the download link for the tgz file :-)

Share this post


Link to post

After I executed the two terminal commands, I got the warning message that library is in progress (don't know if it worked before), but it did not end. So I killed it and it seems to work now.

 

Sent you a pm on last.fm (didn't find the button here xD) with the download link for the tgz file :-)

 

From the debug files you provided, It looks like it is working fine. The library creation was in progress, 103 tracks are processed.

Don't forget that the first time, it downloads every artwork so it can take a while!

 

So if you killed the update library, you can restart it by executing "update library".

 

Then be patient :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...