Jump to content
vdesabou

Spotify Mini Player: Control your Spotify library at your fingertips

Recommended Posts

I named the playlist "Alfred Playlist" as instructed, but when I tried to set the Alfred Playlist I got this:

 

PlzF.png

 

 

Share this post


Link to post

I named the playlist "Alfred Playlist" as instructed, but when I tried to set the Alfred Playlist I got this:

 

PlzF.png

 

Hi,

 

Can you try to access in a web browser https://embed.spotify.com/?uri=<the spotify uri of your playlist>

 

For example, mine is:

 

https://embed.spotify.com/?uri=spotify:user:vdesabou:playlist:20SZYrktr658JNa42Lt1vV

 

You should be able to see your playlist. If not, then there is something wrong with your playlist

Share this post


Link to post

It worked in the browser, I just tried and I was able to set the URL in Alfred now, not sure what was wrong before. My playlist was empty originally and I dragged a random song to it, not sure if that made a difference. Thanks for your help!

 

Share this post


Link to post

It worked in the browser, I just tried and I was able to set the URL in Alfred now, not sure what was wrong before. My playlist was empty originally and I dragged a random song to it, not sure if that made a difference. Thanks for your help!

 

I think it's because of the time it takes for the playlist to be synchronized on Spotify servers. When I validate the name of the playlist, I have to lookup online the playlist, if the synchronization has not been done yet, the lookup does not return results.

 

When you add a song to your Alfred Playlist, it also takes time to be synchronized to Spotify servers. I wait 15 seconds before refreshing the playlist in the workflow, but sometime it is not enough, that's why I added an option to refresh Alfred Playlist.

 

Cheers

Share this post


Link to post

I am happy to announce a major update for this workflow:

 

3.0:

  • Major speed improvements. Using a library with 18000 tracks, search scope set to ALL, with artworks displayed, it takes 150ms to return 50 results
  • Launch your top list
  • Online mode: Lookup for artist online and then browse all albums and tracks
  • Many more improvements

 

PLEASE UPDATE YOUR LIBRARY AFTER INSTALLING THIS NEW VERSION

Share this post


Link to post

Performance is fine all things considered - most results come back in <5s however opening some of my larger playlists can take up to 30s but to be honest most of the time I just launch playlist without browsing it first so that's not really an issue

 

I do have it set to search all my playlists and max results is set to 100 so I wasn't expecting instantaneous results with a library of my size :-P

 

I made major improvements with version 3.0. Using your library I can set max results to 100 and it takes only 150 ms to get results!!

You should definitely have a try!

 

Cheers

Share this post


Link to post

Many thanks for your great work, really appreciate it!

 

Still, I've got a problem concerning the installation. I've downloaded the newest version of Spotify and registered for the developer API. Whenever I try to launch the Mini player I only get the following window.

 

Do you have an idea what I could possibly try to get it working?

 

Thanks alot!

 

sgr59i.png

 

Hi,

 

Yes, some thing wrong is happening here :-)

Can you provide the output.log and output_action.log files that are located in the Spotfify mini player workflow folder? 

Share this post


Link to post

Hi,

 

Yes, some thing wrong is happening here :-)

Can you provide the output.log and output_action.log files that are located in the Spotfify mini player workflow folder? 

 Any feedback?

Share this post


Link to post

Oh, I'm sorry! Apparently, my notifications for the forum didn't work properly...

 

Output_action.log is empty.

This one's from output.log:

 

Hi,

 

You have two issues:

 

1/ This error:

 

 

2013-08-01 11:19:05.700 osascript[4093:f0b] Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types:  dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:
/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition "/Library/ScriptingAdditions/Adobe Unit Types.osax" declares no loadable handlers.
 
I found this on internet. Can you follow the instructions to fix it: http://robpickering.com/2011/01/adobe-type-units-error-how-to-fix-it-343
 

2/ Error: no such table: counters

 

After fixing 1, try to update your library. If you still get an issue, please provide your library.db and settings.db in the spotify mini player application  support directory (ping me if you don't know where it is)

 

Keep me posted!

Share this post


Link to post

Hello,

 

sorry for my bad englisch …

 

The Miniplayer doesn't work for me. Alfred shows "Library update in progress" for 2 days.

 

The /Users/(me)/Spotify folder is empty.

 

Thanks.

Share this post


Link to post

Hello,

 

sorry for my bad englisch …

 

The Miniplayer doesn't work for me. Alfred shows "Library update in progress" for 2 days.

 

The /Users/(me)/Spotify folder is empty.

 

Thanks.

Hi,

 

I have the same problem as beetlefrosch.  I followed all the steps but the "Library update in progress" never ends.  It's been running for 12 hours now and I only have a few playlists and I would not consider my iTunes library (if it is caching those images too) to be very large either.  Is there any other way of getting this step completed or speeding it up ?

 

I'm using the latest version from the first post on the first page of this thread.

 

My Users/Spotify directory is not empty.

It contains the spotify-app-miniplayer directory, the css and js subdirectories and icon.png, index.html and manifest.json files within the spotify-app-miniplayer folder

 

Many thanks

Edited by mobelby

Share this post


Link to post

Hello,

 

sorry for my bad englisch …

 

The Miniplayer doesn't work for me. Alfred shows "Library update in progress" for 2 days.

 

The /Users/(me)/Spotify folder is empty.

 

Thanks.

 

Hi, Can you share the output.log and output_actions.log that are located in the workflow folder?

 

Hi,

 

I have the same problem as beetlefrosch.  I followed all the steps but the "Library update in progress" never ends.  It's been running for 12 hours now and I only have a few playlists and I would not consider my iTunes library (if it is caching those images too) to be very large either.  Is there any other way of getting this step completed or speeding it up ?

 

I'm using the latest version from the first post on the first page of this thread.

 

My Users/Spotify directory is not empty.

It contains the spotify-app-miniplayer directory, the css and js subdirectories and icon.png, index.html and manifest.json files within the spotify-app-miniplayer folder

 

Many thanks

 

Can you share the output.log and output_actions.log that are located in the workflow folder?

 

Thanks

Share this post


Link to post
output.log
 
<?xml version="1.0"?>
<items><item uid="" arg="/Users/oliver/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/update_library_in_progress" valid="no" autocomplete=""><title>Library update in progress</title><subtitle>Please come back later</subtitle><icon>./images/warning.png</icon></item></items>
 

The output_action.log is empty and 0 Byte

Share this post


Link to post

 

output.log
 
<?xml version="1.0"?>
<items><item uid="" arg="/Users/oliver/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/update_library_in_progress" valid="no" autocomplete=""><title>Library update in progress</title><subtitle>Please come back later</subtitle><icon>./images/warning.png</icon></item></items>
 

The output_action.log is empty and 0 Byte

 

 

Ok, Can you delete the file "update_library_in_progress" in the same folder, and then do an install/update library and then provide the output.log.

Can you also check that you have a "spotify-app-miniplayer" folder in the same folder?

Share this post


Link to post

The folder "spotify-app-miniplayer" exists, the file "update_library_in_progress" isn't there.

 

Sorry, it is in /Users/YOUR_USER/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player directory

Share this post


Link to post

Ok, Can you delete the file "update_library_in_progress" in the same folder, and then do an install/update library and then provide the output.log.

Can you also check that you have a "spotify-app-miniplayer" folder in the same folder?

I've done this and here's my output.log:

 

 

<?xml version="1.0"?>
<items><item uid="" arg="/Users/mtimesm/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/update_library_in_progress" valid="no" autocomplete=""><title>Library update in progress</title><subtitle>Please come back later</subtitle><icon>./images/warning.png</icon></item></items>
 
 
My output_action.log is empty and zero bytes
Edited by mobelby

Share this post


Link to post

Sorry, it is in /Users/YOUR_USER/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player directory

output.log:

<?xml version="1.0"?>
<items><item uid="" arg="" valid="no" autocomplete=""><title>Workflow is not configured, library.db is missing</title><subtitle>Select Open Spotify Mini Player App below, and copy json data</subtitle><icon>./images/warning.png</icon></item><item uid="" arg="|||||||open_spotify_export_app||" valid="yes" autocomplete=""><title>Open Spotify Mini Player App <spotify:app:miniplayer></title><subtitle>Once clipboard contains json data, get back here and use Install library.</subtitle><icon>./images/app_miniplayer.png</icon></item><item uid="" arg="|||||||update_library_json||" valid="yes" autocomplete=""><title>Install library</title><subtitle>Make sure the clipboard contains the json data from the Spotify App <spotify:app:miniplayer></subtitle><icon>./images/update.png</icon></item><item uid="" arg="" valid="no" autocomplete="Settings→"><title>Settings</title><subtitle>Search scope=<only ★>, Max results=<50>, Spotifious is <enabled>, Alfred Playlist is <enabled></subtitle><icon>./images/settings.png</icon></item></items>

output_action.log


Warning: opendir(/Users/oliver/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/artwork): failed to open dir: No such file or directory in /Users/oliver/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.B481C81C-2890-4A00-8DEB-F80F71AC64E0/functions.php on line 194
ERROR: JSON data is not valid!

Share this post


Link to post

Warning: opendir(/Users/oliver/Library/Application Support/Alfred 2/Workflow Data/com.vdesabou.spotify.mini.player/artwork): failed to open dir: No such file or directory in /Users/oliver/Dropbox/Alfred/Alfred.alfredpreferences/workflows/user.workflow.B481C81C-2890-4A00-8DEB-F80F71AC64E0/functions.php on line 194
ERROR: JSON data is not valid!

 

The error JSON data is not valid means that when you selected the install library action, the clipboard did not contain your JSON library. You need to follow the steps in "First time use" in the first post, specifically the step where you select the JSON data in the box and copy it to clipboard, right before install/update the library.

 

Let me know if this is enough clear

Share this post


Link to post

The error JSON data is not valid means that when you selected the install library action, the clipboard did not contain your JSON library. You need to follow the steps in "First time use" in the first post, specifically the step where you select the JSON data in the box and copy it to clipboard, right before install/update the library.

 

Let me know if this is enough clear

That the problem. Spotify says "Application is not installed". I have logout an login and the same.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...