Jump to content
vdesabou

Spotify Mini Player: Control your Spotify library at your fingertips

Recommended Posts

Done, everything, but it still does not work. Still having my initial problem.

 

So did you get the same output as in comment #100 ? Or empty window in Alfred?

 

Can you please share output logs?

Share this post


Link to post

So did you get the same output as in comment #100 ? Or empty window in Alfred?

 

Can you please share output logs?

 

The logs I've send you are the only ones created. If you want to continue this conversation by email I'm okay with that.

Share this post


Link to post

The logs I've send you are the only ones created. If you want to continue this conversation by email I'm okay with that.

 

I tried to send you a PM but I got:

 

 

The following errors were found

The member timkro can not use the messaging system

This personal message has not been sent

 

 

Do you have an email I can use?

 

 

 

 

Here is my current understanding of the situation:

 

After installing the workflow, you followed steps in "First time use":

 

 

First time use

You'll need to do the following steps:

[vdesabou] you did it

  • Download the latest version of Spotify and install it (I had to do it, even though I was pretty sure to already have the latest version, so please do it!)

[vdesabou] you did it

 

  • Open Spotify Mini Player app (it is automatically installed) by invoking spot_mini or configured hotkey in Alfred, and select "Open Spotify Mini Player App":

GH1O+.png

 

[vdesabou] you have never seen this, because the only thing you get is a blank window, and the output.log contains:

 

 

ln: /Users/timkro/Spotify/spotify-app-miniplayer: File exists

<?xml version="1.0"?>

<items><item uid="519b34a5c422e" arg="" valid="no" autocomplete=""><title>Workflow is not configured, library.json is missing</title><subtitle>Select Open Spotify Mini Player App below, and copy json data</subtitle><icon>./images/warning.png</icon></item><item uid="519b34a5c4252" arg="||||||||open_spotify_export_app" valid="yes" autocomplete=""><title>Open Spotify Mini Player App <spotify:app:miniplayer></title><subtitle>Once clipboard contains json data, get back here and use Install library.</subtitle><icon>./images/app_miniplayer.png</icon></item><item uid="519b34a5c425c" arg="||||||||update_library_json" valid="yes" autocomplete=""><title>Install library</title><subtitle>Make sure the clipboard contains the json data from the Spotify App <spotify:app:miniplayer></subtitle><icon>./images/update.png</icon></item><item uid="519b34a5c4268" arg="" valid="no" autocomplete="Settings→"><title>Settings</title><subtitle>Current: Search Scope=<only ★>, Max Results=10, Spotifious is disabled, Alfred Playlist is enabled</subtitle><icon>./images/settings.png</icon></item></items>

 

 

Can you confirm these points before going further in troubleshooting?

 

Thanks

Share this post


Link to post

I tried to send you a PM but I got:

 

 

The following errors were found

The member timkro can not use the messaging system

This personal message has not been sent

 

 

Do you have an email I can use?

 

 

 

 

Here is my current understanding of the situation:

 

After installing the workflow, you followed steps in "First time use":

 

 

First time use

You'll need to do the following steps:

[vdesabou] you did it

  • Download the latest version of Spotify and install it (I had to do it, even though I was pretty sure to already have the latest version, so please do it!)

[vdesabou] you did it

 

  • Open Spotify Mini Player app (it is automatically installed) by invoking spot_mini or configured hotkey in Alfred, and select "Open Spotify Mini Player App":

GH1O+.png

 

[vdesabou] you have never seen this, because the only thing you get is a blank window, and the output.log contains:

 

 

ln: /Users/timkro/Spotify/spotify-app-miniplayer: File exists

<?xml version="1.0"?>

<items><item uid="519b34a5c422e" arg="" valid="no" autocomplete=""><title>Workflow is not configured, library.json is missing</title><subtitle>Select Open Spotify Mini Player App below, and copy json data</subtitle><icon>./images/warning.png</icon></item><item uid="519b34a5c4252" arg="||||||||open_spotify_export_app" valid="yes" autocomplete=""><title>Open Spotify Mini Player App <spotify:app:miniplayer></title><subtitle>Once clipboard contains json data, get back here and use Install library.</subtitle><icon>./images/app_miniplayer.png</icon></item><item uid="519b34a5c425c" arg="||||||||update_library_json" valid="yes" autocomplete=""><title>Install library</title><subtitle>Make sure the clipboard contains the json data from the Spotify App <spotify:app:miniplayer></subtitle><icon>./images/update.png</icon></item><item uid="519b34a5c4268" arg="" valid="no" autocomplete="Settings→"><title>Settings</title><subtitle>Current: Search Scope=<only ★>, Max Results=10, Spotifious is disabled, Alfred Playlist is enabled</subtitle><icon>./images/settings.png</icon></item></items>

 

 

Can you confirm these points before going further in troubleshooting?

 

Thanks

I have seen that dialog box you posted with:

Workflow not configured

Open Spotify

Install Library

Settings

 

I did open Spotify, got the code on my clipboard (pasted in TextEdit to test if it was really on my clipboard) and choose Install Library. But then nothing happened. Did that many times yesterday and today. Today suddenly when I did it for the first time today, the outputlog I've send arrived. 

 

You can contact me at ####

Edited by timkro

Share this post


Link to post

I have seen that dialog box you posted with:

Workflow not configured

Open Spotify

Install Library

Settings

 

I did open Spotify, got the code on my clipboard (pasted in TextEdit to test if it was really on my clipboard) and choose Install Library. But then nothing happened. Did that many times yesterday and today. Today suddenly when I did it for the first time today, the outputlog I've send arrived. 

 

You can contact me at tim(a)timkro(DOT)nl

 

I believe I've found the issue you're experiencing, can you try version 2.6:

 

 

Download Workflow

History

2.6:

  • Fix issue during library creation where nothing happened

Share this post


Link to post

For some reason the spotify mini player has stopped working for me, when I run 'spotify:app:miniplayer' in spotify search I get the screenshot below???

 

Screen_Shot_2013_05_22_at_18_12_33.png

 

Can you check that ~/Spotify/spotify-app-miniplayer is a valid directory with files in there?

Share this post


Link to post

This is what I have 

 

Screen_Shot_2013_05_22_at_18_19_57.png

 

This is not good, this must be a directory. I don't know why this is happening for some users...Need to investigate

 

Can you try:

 

1/ delete this file and then just relaunch spotify mini player (if the directory does not exist, the workflow create a symbolic link)

 

2/ if 1 is not working, can you delete the file again and then copy directly the directory from workflow folder in ~/Spotify

Share this post


Link to post

Hi,

 

This sounds like a very good workflow but I get a problem when making it working... I followed the steps you were mentioning :

- create developer account on spotify

- uninstall current version of spotify and install a fresh new one

- tap "spot_mini" and click on the 2nd output.

 

But when I do that, I have the following on Spotify :

454185Capturedcran20130524191836.png

 

I then tried to restart Spotify, to reconnect and even to re-install again, but it is always displaying the same error...

 

Do you know a way to make it work ?

 

Thanks,

Axel

Share this post


Link to post

Hi,

 

This sounds like a very good workflow but I get a problem when making it working... I followed the steps you were mentioning :

- create developer account on spotify

- uninstall current version of spotify and install a fresh new one

- tap "spot_mini" and click on the 2nd output.

 

But when I do that, I have the following on Spotify :

 

 

I then tried to restart Spotify, to reconnect and even to re-install again, but it is always displaying the same error...

 

Do you know a way to make it work ?

 

Can you check that you have a folder in ~/Spotify/spotify-app-miniplayer and not something like in #115

If so follow instructions I gave after.

 

If this is something else, let me know and I will help!

Cheers

Share this post


Link to post

Yes I already checked that, at first I had only a symbolic link to the folder that was in the workflow folder. So I tried to copy the folder in the spotify folder but this didn't change anything...

 

Thanks for your help anyway !

Share this post


Link to post

Yes I already checked that, at first I had only a symbolic link to the folder that was in the workflow folder. So I tried to copy the folder in the spotify folder but this didn't change anything...

 

Thanks for your help anyway !

 

Weird..

 

Are you sure you are signed up for developer account, you should see in http://developer.spotify.com :-

 

ObT6+.png

 

 

Do you login with a facebook account? A user already have an issue but he only had to login/logout to make it work.

 

Did you download and install the latest version of spotify after you signed up for dev account?

 

Otherwise you can also try to install another app, to see if the problem is related to spottify-miniplayer or not. follow installation instructions here https://github.com/spotify/apps-tutorial

Share this post


Link to post

I actually signed up in spotify but I probably made a mistake because I did it again and now it's working perfectly !

 

Thanks for your time ;)

Ok good news, thanks for the feedback

Share this post


Link to post

Hi,

 

Are you talking about the spotify app here? If so, what do you see when you set "spotify:app:miniplayer" in the spotify search bar?

Can you check that you have a directory spotify-app-miniplayer in ~/Spotify ?

 

When I search "spotify:app:miniplayer" I get the message "Application is not installed" (see screenshot) 

 

Screen+Shot+2013-05-28+at+13.54.49.png

 

I have the files you mention in Users/[Me]/Library/Application_Support/Spotify (see screenshot)

 

Screen+Shot+2013-05-28+at+14.28.32.png

Share this post


Link to post

 

I have the files you mention in Users/[Me]/Library/Application_Support/Spotify (see screenshot)

 

 

 

Yes that's normal, but the important thing is that it shall be also in /Users/[you]/Spotify directory 

Share this post


Link to post

Procedure doesnt work. I cant get passed open spot_mini because spotify tells me it "failed to load application miniplayer". Have tried restarting and reinstalling the new one.

 

Can you try the latest version here:

 

Download Workflow

History

2.7:

  • Attempt to better detect problems with spotify-app-miniplayer app

 

If after installing version 2.7, you still get the spotify error with the spotify-app-miniplayer, then follow steps in my comment             #121            

Let me know how it goes.

Share this post


Link to post

Can you try the latest version here:

 

Download Workflow

History

2.7:

  • Attempt to better detect problems with spotify-app-miniplayer app

 

If after installing version 2.7, you still get the spotify error with the spotify-app-miniplayer, then follow steps in my comment             #121            

Let me know how it goes.

 

Figured it out. There is an extra step missing from your guide. You have to check a check mark that allows app apis on the spotify website, otherwise it won't work. Thank you for the work, I really like this workflow!!!

Share this post


Link to post

Figured it out. There is an extra step missing from your guide. You have to check a check mark that allows app apis on the spotify website, otherwise it won't work. Thank you for the work, I really like this workflow!!!

 

Oh I see! Thanks for pointing this out.

I'll add a note in the description to not forget to check this option.

Cheers!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...